Download Asteroid Conflict for Windows: Download (27 MB)

The frameworks XNA 3.1 and .Net 3.5 are required and have to be installed by the user. The installation files for those frameworks are included in the Zip-package. This game is free to share as long as you don´t change the content of this package, sell it or publish it as your own work.